The League of Extraordinary Packages

Our Packages:

Presented by The League of Extraordinary Packages

Getting Started

Adapters

Upgrade to 1.0.0

While version 1.0.0 is largely backwards compatible from earlier versions in every day usage, some parts require a different boostrapping.

Relocated Adapters

In order to have better dependency management, and to remove some of the version contstraints, some of the adapters have been moved out of the main repository. These adapters are:

Caching

Caching has been removed from the main Filesystem class and is now implemented as an adapter decorator.

Version 0.x

$filesystem = new Filesystem($adapter, $cacheAdapter);

Version 1.0.0

Install the required adapter decorator:

composer require league/flysystem-cached-adapter

And convert the bootstrapping to:

use League\Flysystem\Adapter\Local;
use League\Flysystem\Cached\CachedAdapter;

$decoratedAdapter = new CachedAdapter($adapter, $cacheAdapter);
$filesystem = new Filesystem($decoratedAdapter);

Helper Methods

In order to clean up the Filsystem class, some helper functions have been moved to plugins.